通达信波段指标公式

双趋势波段指标:

{超级波段王}
VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),COLORRED ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),COLORGREEN ;
Q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
AA:3*Q3-2*Q4 ,COLORYELLOW;
Q5:=AA>1*REF(AA, 1);
Q6:=LLVBARS(LOW, 50);
Q7:=SUM(VOL, Q6);
Q8:=HHVBARS(HIGH, 50);
Q9:=SUM(VOL, Q8);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
Q11:=HHV(AA,5);
A1:EMA(Q3, 3) , COLORFFDDCC;
A2:EMA(A1, 3) , COLORFFBBCC;
A3:EMA(A2, 3) , COLORFF99CC;
A4:EMA(A3, 3) , COLORFF55CC;
A5:EMA(A4, 3) , COLORFF33CC;
A6:EMA(A5, 3) , COLORFF11CC;
A:EMA(A4, 3), COLORFF00CC;
DRAWTEXT(CROSS(AA, 20) AND Q10<-13,10,‘☆大底‘), COLOR00FF00;
DRAWTEXT(CROSS(AA, A5) AND REF(AA,1)<34,REF(AA,1),‘☆发财了‘), COLORRED ;
DRAWTEXT(CROSS(A1, AA) AND REF(AA,1)>80, REF(AA,3), ‘☆闪人‘), COLORCFB53B ;
DRAWTEXT(CROSS(AA, A1) AND Q5 AND A1<20 AND Q1>9 OR A1>1*REF(A1, 1)
AND Q1>4 AND A1<60, 30, ‘拉‘), COLORFFFFCC;

波段雄鹰:

VAR1:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1);
VAR4:=EMA(VAR3,5);
VAR5:=LLV(LOW,26);
VAR6:=HHV(HIGH,34);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*4,4)*25;
VAR8:=(2*C+H+L)/4;
VAR9:=LLV(LOW,N1);
VAR10:=HHV(HIGH,N2);
VAR2W:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:= EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND M1<20;
MG1:=IF(CROSS(M1,MW) AND REF(MW,1)>80,80 ,0) ;
波段:EMA((VAR8-VAR9)/(VAR10-VAR9)*100,9),COLORMAGENTA;
B1:EMA(0.667*REF(波段,1)+0.333*波段,2),COLOR00FF00;
顶:IF((BARSLAST(MG1>0)<2),80,100);
底:IF((MB1),20,0);
底预备: IF((VAR7<10),50,30);
顶预备: IF((VAR7>90),50,70);
STICKLINE((波段-B1)>0,波段,B1,3,0),COLORMAGENTA;
STICKLINE((波段-B1)<0,波段,B1,3,0),COLOR00FF00;
DRAWTEXT(CROSS(波段,20),18,‘买入‘),COLORRED;
DRAWTEXT(CROSS(80,波段),82,‘卖出‘),COLORGREEN;
0;100;

波段鬼王:

VAR2:=1/WINNER(CLOSE);
VAR3:MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
看(我)实力:=(100-VARA);
散户:=MA(WINNER(CLOSE*0.95)*100,3);
新庄:=(100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0));
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
断子绝生:= IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50;
DRAWICON(VARD,HIGH,2);
DRAWTEXT(VAR20,C,‘★‘),COLORYELLOW;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,C*1.01,‘有钱不赚傻‘), COLORYELLOW;
DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,HIGH*1.01,‘赚钱我走啦‘),COLOR00FF00;
VAR26:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
波段王:= SMA(VAR28,3,1);
波段鬼:= SMA(波段王,3,1);
地狱:DRAWICON(CROSS(波段王,波段鬼) AND 波段王<40,LOW,1);
天堂: DRAWICON(CROSS(波段鬼,波段王) AND 波段鬼>75,HIGH,2);
DRAWTEXT(CROSS(波段王,波段鬼) AND 波段王<40,LOW*1.01,‘低吸做波段‘), COLORWHITE;
DRAWTEXT(CROSS(波段鬼,波段王) AND 波段鬼>75,HIGH*1.01,‘减磅是老师‘),COLOR00FF00;

波段抄底:

{入市建仓}
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
备钱:IF(VAR8>REF(VAR8,1),0,VAR8),COLOR0FFFFF,NODRAW;
界:0,COLORFFFFFF;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)
启动:IF(XL3,0,VAR8*3),COLORRED,NODRAW;
DRAWBAND(启动,RGB(180,80,200),0,DRAWNULL);
STICKLINE(XL3,0,VAR8*3,4,0),COLORRED;
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,2,0),COLOR10FFFF;
STICKLINE(VAR11>REF(VAR11,1),0,VAR11,4,1),COLORFFF810;
DRAWICON(VAR11>REF(VAR11,1) AND CROSS(VAR11,VAR12),VAR11,11);
40,POINTDOT;
VA:=(C+2*H+L)/4;
VB:=LLV(L,8);
VC:=HHV(H,8);
VD:=EMA(((VA-VB)/(VC-VB)-VC/VB)*81,5)*-1;
红线上穿买:REVERSE(VD)+100,COLORRED;
红线下穿卖:EMA(红线上穿买,3),COLORFFFF00;
DRAWBAND(红线上穿买,RGB(150,030,030),红线下穿卖,RGB(20,150,20));
IF(红线上穿买>=红线下穿卖,红线上穿买,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
IF(红线上穿买<红线下穿卖,红线上穿买,DRAWNULL),COLORGREEN,LINETHICK2;
散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWICON(CROSS(散户,庄家) AND 散户<30,红线上穿买*0.98,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,红线上穿买*1.02,2);
极品底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),COLORFF00FF,NODRAW;
DRAWICON((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,-3,25);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,红线上穿买*0.9,‘短‘),COLORLIRED;
DRAWICON(CROSS(J,REF(J+0.01,1)) AND X AND J<16,红线上穿买,7);
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
机会来临:SMA(QVAR1C,13,1),COLORCCCC00,LINETHICK2;
STICKLINE(机会来临>90,90,机会来临,2,0),COLORCYAN;
IF(机会来临>=REF(机会来临,1),机会来临,DRAWNULL),COLORCC33CC,LINETHICK2;
中线:EMA(机会来临,55),COLOR9933FF,LINETHICK2;
IF(中线
AAS:=FILTER((COUNT((机会来临-QVAR1D<(-65)),3)=3),34);
波段买点:IF(AAS,15,0),COLORFFFFFF,NODRAW;
DRAWTEXT(AAS,32,‘波段买‘),COLORFFFFFF;
STICKLINE(AAS,0,31,0.3,0),COLORMAGENTA;
DRAWICON(CROSS(机会来临,QVAR1D),机会来临,23);

{DDX预警}
JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000);
DX:=MA(DDX,5)*20;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
DDX3:=EMA(DDX2,5);
预警:=DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2);
STICKLINE(预警,40,50,1,0),COLORLIRED;
{密码1号}
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
STICKLINE(A AND B ,40,47,2,0),COLORRED;
{横盘突破}
O1:=(SUM(EMA((CLOSE+LOW)/2,1)/3,3));
CP1:=HHV(O1,20);
CP2:=HHV(O1,1);
AV:=CROSS(CP2,CP1);
STICKLINE(AV,40,45,4,0),COLORLIMAGENTA;
 

波段之星:

拉升力:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,30)-LLV(LOW,36))*0.6*CLOSE;
拉升力A:=SMA(拉升力,6.3,1);
波峰波谷:SMA(拉升力A,3,1),COLORFF00FF;
拉升力B:=3*拉升力A-2.1*波峰波谷;
空方:=3*波峰波谷-1* 拉升力A;
做空:IF(空方>拉升力B,拉升力B,空方),LINETHICK2,COLOR00FF00;
做空周期:HHV(做空,21),COLORBLUE,LINETHICK2;
多头:IF(做空>=REF(做空,1) ,做空,DRAWNULL),COLORRED,LINETHICK3;
DRAWICON(做空>=REF(做空,1) AND REF(做空,1)
空头:IF(做空
{DRAWICON(做空<=REF(做空,1) AND REF(做空,1)>REF(做空,2),做空,19);}
短线:(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*20,LINETHICK0,COLORWHITE;
中线:(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*20,LINETHICK0,COLORYELLOW;
红柱:SMA(短线,3,1),LINETHICK0,COLOR0000FF;
蓝柱:SMA(中线,3,1),COLORSTICK,COLORFFFF00;
{红柱}
STICKLINE(红柱0,0,红柱,2,0),COLOR888800;
STICKLINE(红柱0,0,红柱,1.5,0),COLORAAAA00;
STICKLINE(红柱0,0,红柱,0.8,0),COLORDDDD00;
STICKLINE(红柱0,0,红柱,0.3,0),COLORFFFF00;
STICKLINE(红柱>REF(红柱,1)AND 红柱>0,0,红柱,2,0),COLOR000088;
STICKLINE(红柱>REF(红柱,1)AND 红柱>0,0,红柱,1.5,0),COLOR0000AA;
STICKLINE(红柱>REF(红柱,1)AND 红柱>0,0,红柱,0.8,0),COLOR0000DD;
STICKLINE(红柱>REF(红柱,1)AND 红柱>0,0,红柱,0.3,0),COLOR0000FF;
STICKLINE(蓝柱0,0,蓝柱,2,0),COLOR008800;
STICKLINE(蓝柱0,0,蓝柱,1,0),COLOR00AA00;
STICKLINE(蓝柱0,0,蓝柱,0.8,0),COLOR00DD00;
STICKLINE(蓝柱0,0,蓝柱,0.3,0),COLOR00FF00;
{蓝柱}
STICKLINE(红柱>REF(红柱,1)AND 红柱<0,0,红柱,2,0),COLOR880088;
STICKLINE(红柱>REF(红柱,1)AND 红柱<0,0,红柱,1.5,0),COLORAA00AA;
STICKLINE(红柱>REF(红柱,1)AND 红柱<0,0,红柱,0.8,0),COLORDD00DD;
STICKLINE(红柱>REF(红柱,1)AND 红柱<0,0,红柱,0.3,0),COLORFF00FF;
STICKLINE(红柱<0,0,红柱,2,0),COLOR888800;
STICKLINE(红柱<0,0,红柱,1.5,0),COLORAAAA00;
STICKLINE(红柱<0,0,红柱,0.8,0),COLORDDDD00;
STICKLINE(红柱<0,0,红柱,0.3,0),COLORFFFF00;
STICKLINE(蓝柱>REF(蓝柱,1)AND 蓝柱<0,0,蓝柱,2,0),COLOR009999;
STICKLINE(蓝柱>REF(蓝柱,1)AND 蓝柱<0,0,蓝柱,1.5,0),COLOR00BBBB;
STICKLINE(蓝柱>REF(蓝柱,1)AND 蓝柱<0,0,蓝柱,0.8,0),COLOR00DDDD;
STICKLINE(蓝柱>REF(蓝柱,1)AND 蓝柱<0,0,蓝柱,0.3,0),COLOR00FFFF;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,5,0,4,0),COLOR770077;
STICKLINE(A1,5,0,3,0),COLOR990099;
STICKLINE(A1,5,0,2,0),COLORBB00BB;
STICKLINE(A1,5,0,1,0),COLORDD00DD;
STICKLINE(A1,5,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,5.2,‘全仓‘),COLORRED;

神奇波段:

MX:=EMA(C,2);
MXA:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(MX>=MXA,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLOR600020;
STICKLINE(MX
COLOR404050;
DRAWKLINE(H,O,L,C);
AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
趋势线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORRED;
CC:=(CLOSE/趋势线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-趋势线)/趋势线)/3;
TMP:=MA1-MAAA*MA1;
JJ:IF(TMP<=趋势线,趋势线,DRAWNULL),LINETHICK3,COLORGREEN;
XJ:IF(TMP<=趋势线,TMP,DRAWNULL),LINETHICK2,COLORBLUE;
建仓:CROSS(MX,MXA),NODRAW;
SEL:=CROSS(MXA,MX);
DRAWICON(建仓,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
DRAWTEXT(建仓,L-0.68,‘建仓持股‘)COLORMAGENTA;
DRAWTEXT(SEL,H+0.38,‘清仓持币‘),COLORBLUE;
STICKLINE(MX>=MXA,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(MX>=MXA,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(MX
STICKLINE(MX
STICKLINE(建仓,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;
CP:=MA(CLOSE,9),COLORCYAN,LINETHICK1;
JD:=MA(CLOSE,18),COLORMAGENTA;
DRAWICON(CROSS(CP,JD) AND MX>=MXA,JD-0.1,1);
DRAWTEXT(CROSS(CP,JD) AND MX>=MXA,JD-0.38,‘加仓‘),COLORYELLOW;
BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(FILTER(BL,3),H+0.2,‘倍量柱‘)COLORYELLOW;
STICKLINE(FILTER(BL,3),OPEN,CLOSE,1.5,0),COLORYELLOW;
XG:=SUMBARS(FILTER(BL,3),1);
STICKLINE(XG,REF(L,XG-1),REF(L,XG-1),10,0),COLORYELLOW;

神奇波段线:

趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1),COLORYELLOW;
DRAWBAND(趋势,RGB(155,50,50),50,RGB(0,100,50));
{STICKLINE(趋势>50,趋势,50,6,0),COLORFF00FF;
STICKLINE(趋势<50,趋势,50,6,0),COLORGREEN;}
转强:IF(趋势>50,趋势,DRAWNULL),COLOR0000FF;
转弱:IF(趋势<50,趋势,DRAWNULL),COLORGREEN;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,2,0),COLORYELLOW;
STICKLINE(转点=0,50,50,2,0),COLORCYAN;
STICKLINE(C,90,90,1,0),COLORYELLOW;
STICKLINE(C,10,10,1,0),COLORCYAN;
判断:SMA(趋势,3,1),COLORYELLOW;
IF(判断>50 AND 趋势>判断,判断,DRAWNULL ),COLORYELLOW,LINETHICK2;
IF(判断<50 AND 趋势>判断,判断,DRAWNULL),COLORFF00FF;
IF(判断>50 AND 趋势<判断,判断,DRAWNULL),COLORGREEN,LINETHICK2;
风险区:80,COLORFF85FF,POINTDOT;
安全区:20,COLORYELLOW,POINTDOT;
顶部:90,COLORFFFF00;
强弱线:50,COLORGREEN,POINTDOT;
DRAWICON(CROSS(趋势,判断) AND 趋势<80 ,判断,1);
DRAWICON(CROSS(趋势,顶部),顶部,2);
LC:= REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势1: IF(VAR6>45,VAR6-45,0),COLOR00FFFF;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(火焰山>0,0 ,火焰山*1.2,3,0 ),COLOR4444FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,2,0 ),COLOR7777FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,1,0 ),COLOR9999FF;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),3,0),COLOR000033;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2,0),COLOR000077;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1.5,0),COLOR0000BB;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1,0),COLOR0000DD;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),3,0),COLOR003300;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2,0),COLOR007700;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),1,0),COLOR00DD00;
逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,20,3,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,30,2,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,30,1,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,30,0.5,0),COLORFFCC00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
DRAWICON(BBUY,10,1);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),10,2);
DRAWTEXT(CROSS(82,VARR1),35,‘减‘),COLORYELLOW;
神奇线选股:(CROSS(趋势,判断) AND 趋势<80),LINETHICK0;
波段选股:(BBUY),LINETHICK0;
STICKLINE(神奇线选股 AND 波段选股,0,100,1,0),COLORWHITE;
时间: 12-09

通达信波段指标公式的相关文章

通达信财务函数与股票公式进阶篇[转]

http://blog.sina.com.cn/s/blog_676348b301018f6v.html 通达信财务函数与股票公式进阶篇[转] (2012-12-09 17:38:13) 转载▼ 标签: 杂谈   FINANCE(1) 总股本(万股)FINANCE(2) 国家股(万股)FINANCE(3) 发起人法人股(万股)FINANCE(4) 法人股(万股)FINANCE(5) B股(万股)FINANCE(6) H股(万股)FINANCE(7) 流通股本(万股)CAPITAL 流通股本(手)

帮编写做金字塔策略公式、通达信选股公式代写、长短龙行KDJ副图指标公式

飞狐kdj通道指标公式帮编写做金字塔策略公式.通达信选股公式代写.长短龙行KDJ副图指标公式飞狐龙行KDJ副图指标源码原理解析RSV赋值:(收盘价-7日内最低价的最低值)/(7日内最高价的最高值-7日内最低价的最低值)*100输出短K:RSV的3日[1日权重]移动平均,画白色输出短D:短K的3日[1日权重]移动平均,画黄色RSV1赋值:(收盘价-38日内最低价的最低值)/(38日内最高价的最高值-38日内最低价的最低值)*100输出长K:RSV1的5日[1日权重]移动平均,画红色输出长D:长K的

代做通达信指标公式、帮写MT4策略公式

代做通达信指标公式.MT4策略公式调试.蓝色抛售黄色下跌变色主图指标公式飞狐主图立桩指标 飞狐太公变色改进主图指标 原理解析: GN(收盘价的5日简单移动平均>收盘价的10日简单移动平均,收盘价的5日简单移动平均,收盘价的10日简单移动平均)COLOR6699FFVAR1赋值:收盘价的有效数据周期数VAR2赋值:(200日内最高价的最高值-200日内最低价的最低值)/40当满足条件VAR1/30=VAR1/30的向下舍入时,在最高价+VAR2和最高价+VAR2*4位置之间画柱状线,宽度为10,0

代做通达信指标公式、5日市场成本32日市场成本公式

飞狐5分钟换手率指标 代做通达信指标公式.博易大师策略公式调试.5日市场成本32日市场成本主图指标公式飞狐市场成本5日32日主图指标源码原理解析VAR1赋值:成交量(手)/成交量(手)的5日累和输出市场成本(5日): 以VAR1为权重收盘价的动态移动平均VARC赋值:成交额(元)/成交量(手)/100VARD赋值:(3*最高价+最低价+开盘价+2*收盘价)/7VAR10赋值:成交额(元)的34日累和/VARC/100输出市场成本(32日): 以成交量(手)/VAR10为权重VARD的动态移动平均

通达信 唐能通 短线是银选股指标 盘中预警指标公式指南针大智慧

本指标适合通达信使用!指标不是万能的,但没有指标是万万不行的,指标不在于多少,而在于精准,我们的指标都是基于实战,经过实战的无数次检验,一旦拥有就别无所求了.拥有一个精准的好指标,就意味着您身边多了一名专业的分析助理. 我们将在第一时间把指标发给您,如不在,请在"给卖家留言"里填写自己的邮箱,我们会第一时间把指标发到您的邮箱里. ![](http://i2.51cto.com/images/blog/201807/31/460a75d6439c85379e61904c24d09415.

复制带中文的公式贴到通达信公式中显示乱码解决方案

无论是复制带中文的公式进通达信,还是从通达信中复制出来放到文本文件中都会显示乱码, 可以将带中文的内容先粘贴到word中字体选择   等线(中文正文) 然后再复制到目的地即可 原文地址:https://www.cnblogs.com/xiaodebing/p/10201882.html

代做公式选股、同花顺选股公式调试、猎庄主图指标公式指标公式-同花顺公式

原理解析:当满足条件(收阴线)时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR008800当满足条件(收阴线)时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00当满足条件(收阴线)时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR008800当满足条件(收阴线)时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR009900当满足条件(收阴线)时,在收盘价和

股票公式编写、编写股票选股公式、赚钱到手导弹发射买入指标公式

导弹攻击买入 赚钱到手源码 VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;VAR5:=(VAR2+2*VAR3+3*VAR4)/6;VAR6:=MA(VAR5,3);: VAR6

编写选股公式、同花顺选股公式编写、编写涨停三阴线超短选股指标公式、编写选股公式

三阴线超短信号不多,本月共出现两个信号.其他话不多说,效果好不好,大家下载后可以去验证,我说了不算源码 原理解析:A1赋值:4日前的收盘价/5日前的收盘价>=1.097A2赋值:3日前的收盘价=收盘价的5日简单移动平均输出XG:A1 AND A2 AND A3 AND A4 AND A5 AND A6源码: A1:=REF(C,4)/REF(C,5)>=1.097;A2:=REF(C,3)=MA(C,5);XG:A1 AND A2 AND A3 AND A4 AND A5 AND A6;TIP